P0420 question. Please help! - Toyota FJ Cruiser Forum
Engine Performance This forum is for discussion on gas, oil, exhaust and all things engine related.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-18-2019, 12:13 PM Thread Starter
New Member
 
Join Date: Oct 2018
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
P0420 question. Please help!

So, I have only the p0420 code right now and have been using a blue driver (obd 2 scanner) to read all my info. The scanner shows me the cat temps and both banks have just about the exact same temperatures (pictured below) so i'm thinking it isn't my cat. Am I correct in assuming this? From looking at the O2 sensor voltage readings and the fuel trims, the only thing that seems to be off is my long term fuel trim in bank 2. It reads 11.7% (and seems to only increase) while bank 1 only reads 2.3% which is a decrease from where it previously was 10 minutes ago at 3.9%. The only reason I think it IS my cat is that the downstream sensor voltage is fluctuating up and down. Also, if it makes a difference, all this info is with the p0420 code erased. Someone please help. It's a 2007 with roughly 140k miles on it. A few months ago, I was getting a p0420, p0101, p0171, p0174. Then p0420 went away leaving the other 3 codes. After an advance auto MAF replacement sensor, I got a p0300 and p0306. I then got a denso OEM MAF sensor and all previous codes went away but I got rich codes on both banks and I know thhe Fj was running extremely rich. I found out that a toyota technician had bumped one of the air filter rings into the intake tube and was touching the MAF so I removed it and the rich codes went away. I had no codes for a full day of driving and then the p0420 code returned which brings us to today. I've been driving with it for about a month and a half. All help is appreciated.
Attached Thumbnails
Click image for larger version

Name:	IMG_5651.jpeg
Views:	12
Size:	161.0 KB
ID:	1072182   Click image for larger version

Name:	IMG_5649.jpeg
Views:	11
Size:	113.5 KB
ID:	1072184  

Last edited by chasitek; 03-18-2019 at 10:07 PM.
chasitek is offline  
Sponsored Links
Advertisement
 
Reply

  Toyota FJ Cruiser Forum > Toyota FJ Cruiser Discussion > Engine Performance

Tags
p0420

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota FJ Cruiser Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  Similar Threads
Thread Thread Starter Forum Replies Last Post
ARB INSTALL QUESTION on lights and winch mellow-yellow 4x4 / Off-Road Tech 4 11-11-2011 06:54 PM
Newbie ATRAC and Rear Diff Lock question TheBigSmurf Transmissions / Transfer Cases / Traction Aids 11 03-25-2011 03:23 PM
Online parts? (kind of a long question) daehimeh Misc. Technical Discussion 5 03-12-2009 12:14 PM
Real simple question on usable power FuctJimmy Engine Performance 4 11-26-2008 10:03 AM
NEWBIE question fjdany Suspension / Steering Tech 12 09-13-2008 08:59 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome