Weird sounds after installing the Pro Comp 3 inch lift. - Toyota FJ Cruiser Forum
Suspension / Steering Tech All suspension and steering related topics belong in this subforum.

 5Likes
  • 1 Post By SilvFx
  • 1 Post By Thumpedr36
  • 1 Post By Thorn661
  • 1 Post By Thumpedr36
  • 1 Post By Thumpedr36
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-09-2017, 12:32 AM Thread Starter
New Member
 
Join Date: Oct 2016
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
Weird sounds after installing the Pro Comp 3 inch lift.

I just installed the Pro Comp 3 inch lift on my 2007 FJ. Been on for about 400 miles so far. It's rides better than the old stock suspension, however, when I hit tiny bumps it sometimes seems like it skips across the top of the bump without actually working. Almost like the steering goes really loose for a split second. I have checked everything, and everything I had to touch is still tight. Is it that much more stiff, or could there be something that is binded somewhere?

Sent from my SM-G955U using Tapatalk

Last edited by Thumpedr36; 05-09-2017 at 12:35 AM.
Thumpedr36 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-09-2017, 09:30 AM
Forum Superstar
 
SilvFx's Avatar
 
Join Date: Dec 2009
Location: Englewood Colorado
Posts: 1,735
Mentioned: 44 Post(s)
Tagged: 0 Thread(s)
Quoted: 612 Post(s)
Re: Weird sounds after installing the Pro Comp 3 inch lift.

Did you re-do the alignment after after installing the lift? They can be a squirrely on handling if you dont get them aligned after a lift and closer to factory alignment specs.

Your title also mentions weird sound, but i dont see within your post anything describing the sound and when it happens...just the mention of the bump steer issue.

Can you clarify further?
WebSnyper likes this.
SilvFx is offline  
post #3 of 7 (permalink) Old 05-09-2017, 07:31 PM Thread Starter
New Member
 
Join Date: Oct 2016
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
Re: Weird sounds after installing the Pro Comp 3 inch lift.

Just on small bumps it almost sounds like metal hitting metal. Not loud, but annoying as hell. I haven't got it in for an allignyyet because up here in Alaska, it's tire changeover season, and all the shops are two weeks out. I have an appointment though.

Sent from my SM-G955U using Tapatalk
Thorn661 likes this.
Thumpedr36 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 05-09-2017, 07:55 PM
Forum Beer Miester
 
Thorn661's Avatar
 
Join Date: Jan 2015
Location: SW LA
Posts: 4,330
Mentioned: 95 Post(s)
Tagged: 1 Thread(s)
Quoted: 2066 Post(s)
Garage
Lifetime Supporting Member
Re: Weird sounds after installing the Pro Comp 3 inch lift.

Quote:
Thumpedr36 previously said: View Post
I just installed the Pro Comp 3 inch lift on my 2007 FJ. Been on for about 400 miles so far. It's rides better than the old stock suspension, however, when I hit tiny bumps it sometimes seems like it skips across the top of the bump without actually working. Almost like the steering goes really loose for a split second. I have checked everything, and everything I had to touch is still tight. Is it that much more stiff, or could there be something that is binded somewhere?

Sent from my SM-G955U using Tapatalk
Yep dude I'm afraid it is that much more stiff. Wish I could've got to ya before you purchased the Pro Comp because I would've tried to get you to save you're money for a more expensive kit because this kit is pretty harsh. I've got this kit sitting in a shed because I won't even give it away I disliked it so much.

Change the UCA's, align it and it'll get smoother because it's in a bind and this will help a little.

Thorn661 is online now  
post #5 of 7 (permalink) Old 05-09-2017, 08:02 PM
Forum Beer Miester
 
Thorn661's Avatar
 
Join Date: Jan 2015
Location: SW LA
Posts: 4,330
Mentioned: 95 Post(s)
Tagged: 1 Thread(s)
Quoted: 2066 Post(s)
Garage
Lifetime Supporting Member
Re: Weird sounds after installing the Pro Comp 3 inch lift.

Quote:
Thumpedr36 previously said: View Post
Just on small bumps it almost sounds like metal hitting metal. Not loud, but annoying as hell. I haven't got it in for an allignyyet because up here in Alaska, it's tire changeover season, and all the shops are two weeks out. I have an appointment though.

Sent from my SM-G955U using Tapatalk
Check all the ball joint nuts and tie Rod ends to assure they're tight. Also double check the upper and lower coilover mounts. All these things will make a hell of a clunk on small bumps if one's loose.
SilvFx likes this.

Thorn661 is online now  
post #6 of 7 (permalink) Old 05-09-2017, 09:10 PM Thread Starter
New Member
 
Join Date: Oct 2016
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
Re: Weird sounds after installing the Pro Comp 3 inch lift.

Will do. I will go over it all one more time. Thanks for your advice.

Sent from my SM-G955U using Tapatalk
Thorn661 likes this.
Thumpedr36 is offline  
post #7 of 7 (permalink) Old 05-10-2017, 07:10 PM Thread Starter
New Member
 
Join Date: Oct 2016
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
Re: Weird sounds after installing the Pro Comp 3 inch lift.

Believe it or not, It was the sway bar mounts. The idiot that was helping didn't tighten them evidently. I thought I went through everything he did, but I guess not.

Sent from my SM-G955U using Tapatalk
Thorn661 likes this.
Thumpedr36 is offline  
Reply

  Toyota FJ Cruiser Forum > Toyota FJ Cruiser Discussion > Suspension / Steering Tech

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota FJ Cruiser Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome