Abs-vcs trac---all lights - Page 2 - Toyota FJ Cruiser Forum
Transmissions / Transfer Cases / Traction Aids This area is for discussion, questions and problems with the FJ Cruiser's gear train, including topics on A-TRAC, VSC, locking diffs, gear ratios, manual vs. AT, etc.

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 25 (permalink) Old 07-24-2016, 09:16 PM
Desert Moderator
 
amaclach's Avatar
 
Join Date: Jul 2014
Location: Dubai, UAE
Posts: 5,442
Mentioned: 100 Post(s)
Tagged: 1 Thread(s)
Quoted: 2919 Post(s)
Garage
Lifetime Supporting Member
Re: Abs-vcs trac---all lights

In "normal" conditions, those lights would come on when the vehicle is in 4LL with the rear diff locked. There is a hack that many of us have done, where a switch is put on the diff lock signal circuit, which tells the ecu that the diff is locked, so it turns off all the nannies.
With those symptoms, the first place I would check is the connectors on the e-locker on the rear diff. It shouldn't take more than 5 minutes to check they are firmly seated.

Black '14 6MT
Stock bumpers
Some mods

Rear Diff Lock on Demand mod: https://www.fjcruiserforums.com/foru...mand-hack.html

Nannies Off Mod: https://www.fjcruiserforums.com/foru...ml#post1183262
amaclach is offline  
Sponsored Links
Advertisement
 
post #12 of 25 (permalink) Old 07-24-2016, 10:11 PM
Forum Superstar
 
Bar3K's Avatar
 
Join Date: Feb 2012
Location: Cheyenne
Posts: 3,916
Mentioned: 73 Post(s)
Tagged: 1 Thread(s)
Quoted: 1862 Post(s)
Lifetime Supporting Member
Re: Abs-vcs trac---all lights

Quote:
WHOZONDEK previously said: View Post
When it first happened i was pulling a trailer with about 800 lbs. Any ideas.
This could be a start.
Do you have trailer lights?
Is the trailer lights factory?

Bar3K is offline  
post #13 of 25 (permalink) Old 07-24-2016, 11:02 PM
LHB
Forum Veteran
 
LHB's Avatar
 
Join Date: Oct 2014
Location: Dallas TX
Posts: 417
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 124 Post(s)
Re: Abs-vcs trac---all lights

You might want to stop by Autozone.

They will read your error codes for free.

Then it's just a matter of finding somebody who can decipher them. I used to be able to half-way do it with BMW's but I don't have enough experience with Toyotas yet.

But if you get the error codes there are people here who can help.

2014 FJ Cruiser. Army Green Urban and Rural 4x4 Assault Vehicle.

*Strength and Honor*

"We few, we happy few, we band of brothers." - Shakespeare, Henry V

"I hate rude behavior in a man. I won't tolerate it." - Captain Woodrow F. Call, Lonesome Dove

"If the police catch me I'll end up in the slammer. 'Cause The Law don't want no gear jammers" - George Thorogood and the Delaware Destroyers, Gear Jammer
LHB is offline  
Sponsored Links
Advertisement
 
post #14 of 25 (permalink) Old 08-02-2016, 04:10 PM
New Member
 
Join Date: Feb 2009
Location: Houston
Posts: 12
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to ramiroshelby Send a message via Yahoo to ramiroshelby
Re: Abs-vcs trac---all lights

Hello I have the same lights come on too, abs-vsc-trac. They intermittent while driving or when I put my foot on the break when coming to a stop. Also sometimes I cant' shift out of park into another gear. I have to push on the breaks a couple of times before it will disengaged out of park and if that does not work then I hit the relaase button to get it out of park. So can I get a little help on what sensors I need to look at. I have a 07 2WD. I know it's not 4WD. Thank you for your help.
ramiroshelby is offline  
post #15 of 25 (permalink) Old 08-02-2016, 04:35 PM
Forum Veteran
 
AMMO461's Avatar
 
Join Date: Jun 2014
Location: SO CAL Desert
Posts: 344
Mentioned: 19 Post(s)
Tagged: 0 Thread(s)
Quoted: 162 Post(s)
Garage
Re: Abs-vcs trac---all lights

@WHOZONDEK and @ramiroshelby ,
You both need to have your brake light switch checked and probably replaced. When that switch goes bad it will cause ABS,-VSC,TRAC lights to illuminate. It is an easy check/fix to a pain in the button problem. Let us know what you find out.

"Mean Green" '10 Army green 4x4 AT ATRAC/rear locker. Demello 3 hoop w\BD sqd, Smittybilt M1 Gen2, PURE FJ sliders, EXPO-1 Wash Bottle, Ironman FCP-C's front, Boss 2.5 w/ TOYTEC 2.0 HD rear, SPC DOM LCA. 16" BF 285 KO2 E's on Method NV's.

"Angry Orange" '13 Magma 4x4 AT ATRAC/rear locker, CRAWL. Demello 3 hoop Evil Eye w\BD sqd, Smittybilt M1 Gen2, AP sliders, EXPO-1 Wash Bottle, Ironman FCP-C front, Boss 2.5 w/ TOYTEC 2.0 HD rear. SPC DOM LCA's, 17" BF 285 KO2 E's on Method Holes.
AMMO461 is offline  
post #16 of 25 (permalink) Old 08-03-2016, 05:00 AM
LRP
Forum Regular
 
LRP's Avatar
 
Join Date: Sep 2012
Posts: 287
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Garage
Supporting Member
Re: Abs-vcs trac---all lights

Mine are off and on as well. been so since I bought it in '12. in winter they come on when it's cold but if I warm it up and then restart it most times they stay off. or if they are off for a while they come on when I get on the highway... Here are the codes I pull when I take it to advanced auto;

C1223

U0073
Control Module Communication Bus Off

U0100
Lost Communication With ECM/PCM "A"

U0123
Lost Communication With Yaw Rate Sensor Module

U0124
Lost Communication With Lateral Acceleration Sensor Module

U0126
Lost Communication With Steering Angle Sensor Module

08 TT
US ARMY RETIRED
LRP is offline  
post #17 of 25 (permalink) Old 08-03-2016, 10:35 AM
Forum Master
 
Coldnapalm's Avatar
 
Join Date: Dec 2008
Location: Jacksonville Florida
Posts: 1,531
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Send a message via AIM to Coldnapalm
Re: Abs-vcs trac---all lights

mine came on for a month while i was in Aspen, then they went back off. i dont remember but i think it was something to do with a charcoal filter or something? (just comes to mind may have nothing to do with it)

2007 FJC 6MT
Complete Mods
Vsc Switch
20% tint all around
AllPro 1.5" spacers
old fj link below
Coldnapalm's Rig - Toyota FJ Cruiser Forum
Coldnapalm is offline  
post #18 of 25 (permalink) Old 08-06-2016, 06:42 PM
New Member
 
Join Date: Feb 2009
Location: Houston
Posts: 12
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to ramiroshelby Send a message via Yahoo to ramiroshelby
Re: Abs-vcs trac---all lights

Well I took it to my buddy's shop and hooked it up to the scanner. This is the codes I got back.

C1223 - Fault in ABS Control system

C1246 - Fault in Master Cylender pressure sensor

C1249 - Open circuit in stop light switch circuit

P0504 - Brake Switch A/B correlation

So he did a little research on the P0504 code and read what it said. First step was to leave the vehicle off and push on the breaks to see if the rear breaks will light up. Well my rear break lights did not light up. Well we had to close up shop and went and dropped off my FJ at his house. So went down to the Toyota delearship and bought a new brake light switch. Got back to my friends house and just unplugged the connector from the brake light switch and hooked up the new switch to see if the rear brake lights would come on w/o the vehicle turned on. Well it works. Well I didn't have time to replace the new switch because I needed to drive back to Houston. Well I put about 120 miles with no abs-vsc-trac lights on. Well I got to Houston and check to see if the rear brake lights would come on and they work and I can take it out of park with no problems. I don't have to hit the release button to take it out of park. Well I'm going to take it to another friend in Houston and hook up the scanner again to see if it is still throwing codes. I do have a aftermarket camera system and it plugs to the obII port. I did leave it unhooked on the drive back to Houston to see if the abs-vsc-track lights would come back on. I'm hoping the camara system is not causing the problems, but until the shop opens back up I'll leave it disconnected. Until then.
ramiroshelby is offline  
post #19 of 25 (permalink) Old 08-12-2016, 06:42 PM
New Member
 
Join Date: Feb 2009
Location: Houston
Posts: 12
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to ramiroshelby Send a message via Yahoo to ramiroshelby
Re: Abs-vcs trac---all lights

Well I went to my other friends shop and has him scan again. It is still showing the same errors as previous. So I did change out the brake light switch but didn't have time to go back to my friends shop due to I was called out for work again. I did not hook up the camera system to the OBDII port as of yet. Still don't have the abs-trac-vsc lights. I did leave Houston to go back to Dallas to pack the rest of my cloths to leave to work. While in Dallas I did go get a emissions test and passed. Well in Atlanta, GA now and still no abs-track-vsc lights. I want to run another scan to see if all of the errors have been cleared before I hook the camera back to the OBDII port. The camera system I installed is the Lukas LK-9750. So until then.
ramiroshelby is offline  
post #20 of 25 (permalink) Old 08-18-2017, 11:26 AM
Forum Master
 
ohiobenz's Avatar
 
Join Date: Feb 2009
Location: Summit County Ohio
Posts: 1,470
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 129 Post(s)
Send a message via AIM to ohiobenz Send a message via Yahoo to ohiobenz Send a message via Skype™ to ohiobenz
Lifetime Supporting Member
Re: Abs-vcs trac---all lights

Quote:
LRP previously said: View Post
Mine are off and on as well. been so since I bought it in '12. in winter they come on when it's cold but if I warm it up and then restart it most times they stay off. or if they are off for a while they come on when I get on the highway... Here are the codes I pull when I take it to advanced auto;

C1223

U0073
Control Module Communication Bus Off

U0100
Lost Communication With ECM/PCM "A"

U0123
Lost Communication With Yaw Rate Sensor Module

U0124
Lost Communication With Lateral Acceleration Sensor Module

U0126
Lost Communication With Steering Angle Sensor Module
Quote:
LRP previously said: View Post
Mine are off and on as well. been so since I bought it in '12. in winter they come on when it's cold but if I warm it up and then restart it most times they stay off. or if they are off for a while they come on when I get on the highway... Here are the codes I pull when I take it to advanced auto;

C1223

U0073
Control Module Communication Bus Off

U0100
Lost Communication With ECM/PCM "A"

U0123
Lost Communication With Yaw Rate Sensor Module

U0124
Lost Communication With Lateral Acceleration Sensor Module

U0126
Lost Communication With Steering Angle Sensor Module
Did you ever resolve this?
My 2008 has all the lights on and, according to the dealer who spent 4.5 hrs last time, my ECM is losing communication with the CAN bus.
My ABS is not active
My airbag system is not active
My VSC and traction control are not active
All per the dealer...

Occasionally the ABS light is off, but comes on after driving a while.

For a period of time the brake light was on, but went off.
Yesterday it came on again.

Ive ordered the brake light switch and will replace it today.

Any suggestions?

'08 Fusion: ARB rack, custom ladder, Jerry-can carrier & Hi-lift mount, DO front bumper, Expedition-1 Rear bumper, DO Hybrid Sliders, MileMarker Hyd Winch, SPEC Stage-1 clutch, Icon Stage 2 3" lift, Cobra CB, PNR Snorkel, Spidertrax spacers, All-Pro Skid plates, Airlift airsprings Plasti-Dipped hood, Arco PIAA fogs, Hella drivin lights & more......
ohiobenz is offline  
Reply

  Toyota FJ Cruiser Forum > Toyota FJ Cruiser Discussion > Transmissions / Transfer Cases / Traction Aids

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota FJ Cruiser Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome