Toyota FJ Cruiser Forum banner

61 - 80 of 99 Posts

·
Registered
Joined
·
74 Posts
All,
I have a 2010 TT with OEM subwoofer. After the install, everything works fine except the subwoofer. Any idea? I really appreciate the help.

If this question is in the wrong place, please delete....

Thanks
 

·
Registered
Joined
·
74 Posts
Problem solved.....a simple step of moving the Pin over one slot. :)

All,
I have a 2010 TT with OEM subwoofer. After the install, everything works fine except the subwoofer. Any idea? I really appreciate the help.

If this question is in the wrong place, please delete....

Thanks
 

·
Premium Member
Joined
·
250 Posts
They do, by default; (but check w/ vendor to be sure if possible).
You usually have to let them know if you have the JBL subwoofer, as it requires the Canbus module.
Some vendors ask you to send a pic or the rear of the OEM radio to make sure they send proper harnesses.
D ?
 

·
Registered
Joined
·
74 Posts
I have a non-JBL FJ with OEM subwoofer. For me, the subwoofer does not work by default and I had to move one pin over on the vendor adapter to make it work.
 

·
Registered
Joined
·
9 Posts
Hi, folks. New here. Well, I bought the android head unit and installed by myself, but the emergency lights and defrost are not working. I actually disconnect them. Why? Because the emergency lights start to flash and never stop even if you push the button, so the only way to use the head unit was disconnected them ?, I have turn signals working, but I need that emergency working. My FJ cruiser is 2007... Have any of you have the same issue and have solved? Thank you


I just installed mine and experience the same problems. Emergency lights and defrost not working at all. If you play with flat cable fitting into the connector, I got the same situation as you, emergency lights flash all the time and cannot turn off. I saw rev. 3:11 the same issues.
I also experienced very tight fit into the dashboard (had to cut small plastic corners). Also, when you replace board with commands, my AC button has not enough space to work correctly.

If there is no solution, maybe to make a list of suppliers where to buy/not buy.
I purchased from Aliexpress - effort&BJ Official Store (for 2013 FJ Cruiser)

Does anybody have a 100% fully functional unit?
 

·
Registered
Joined
·
9 Posts
They do, by default; (but check w/ vendor to be sure if possible).
You usually have to let them know if you have the JBL subwoofer, as it requires the Canbus module.
Some vendors ask you to send a pic or the rear of the OEM radio to make sure they send proper harnesses.
D ?
Did you manage to solve emergency/defroster issue?
 

·
Premium Member
Joined
·
250 Posts
Did you manage to solve emergency/defroster issue?
Not yet, I need to trace the OEM wire harness to the unit's, I think the ribbon cable is mismatched by them (?) I did verify continuity to the hazard switch, but still need to verify where they have the +12v & ground.
I will post when (if?) I figure it out. Everything else works fine so I think its just incorrect pin-out to that harness.

D
 

·
Registered
Joined
·
9 Posts
Not yet, I need to trace the OEM wire harness to the unit's, I think the ribbon cable is mismatched by them (?) I did verify continuity to the hazard switch, but still need to verify where they have the +12v & ground.
I will post when (if?) I figure it out. Everything else works fine so I think its just incorrect pin-out to that harness.

D
For sure flat ribbon cable and connector are causing the problem, but how to deal with it?
When I connect cable, em.lights/defr, are not working.
But if remove security connector pin it and "play" with cable, emergency lights start working all the time and cannot be turned on/off (switch not responding)
I tried for 20 min but just cannot find the right position.

I'm thinking to return mine, just its not worth risking failure.
 

·
Registered
Joined
·
1 Posts
News from France !
Hello
AFter some hours to search all informations (thks to Chumley) about my 2013 Fj cruiser diagram wiring , now everything is OK! :)
I found all of these on the Toyota infos website... you have to pay some $ for a 24 to 48 hours ...
To help some of you I put some docs for 2011 to 2014 here:
I bought a adaptator PAC RP4.2-TY11 Radiopro4 ( their canbus is not for the recent OEM car radio)
and this

Now My android 12.3 work fine ! Could have a lot of extras like DAB+ radio, Phone dongle ,ODB data
\




Have a fun !
Reviving this after a year. I'm currently trying to get full functionality of an android based Dasaita head unit. I've got little sound from the rear speakers and sub and trying to figure out amp/sub connections. I saw your files but no 2012. Do you have it still? Curious if it's the same as a 2011.

Thanks in advance.
Carrie
 
61 - 80 of 99 Posts
Top