Toyota FJ Cruiser Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
after installing DT header, y pipe and cat back my vsc lights came on and the check engine. i installed the 02 sim and still check engine and vsc lights ???? help
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
it was the o2 sensors that was throwing everything off, when i took it to the dealership, they called back saying it was reading 10 errors, they refused to work on it with all of this on, so i took it to a couple of different places. Came across AAmotorsports ( AAMotorsports.com) took it apart and found out that the o2 sensors were bad, had them replaced and the car is running great.


:rocker::clap:
 

·
Premium Member
Joined
·
6,956 Posts
it was the o2 sensors that was throwing everything off, when i took it to the dealership, they called back saying it was reading 10 errors, they refused to work on it with all of this on, so i took it to a couple of different places. Came across AAmotorsports ( AAMotorsports.com) took it apart and found out that the o2 sensors were bad, had them replaced and the car is running great.


:rocker::clap:
Glad you got it worked out! I too had the dreaded lights after my header install, still getting them until my O2 sim arrives...

But it sounds like your dealer needs a kick in the nuts... ;)
 

·
Registered
Joined
·
109 Posts
Glad you got it worked out! I too had the dreaded lights after my header install, still getting them until my O2 sim arrives...

But it sounds like your dealer needs a kick in the nuts... ;)
hey!! need help! installed the DT Y-pipe and getting the lights, really driving me nuts. been at the shop two days now, what are my options? assuming its the 02 sensor but already replaced one and they are freaking expensive! any ideas?
 
1 - 5 of 5 Posts
Top