Toyota FJ Cruiser Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
About a week ago I had a quick but unusually noisy start up.

My 07 with 40k miles seemes to be running fine aside from the terrible gas miliage I have been getting lately.......until the dash lit up like a christmas tree. The "CHECK ENGINE", the "VSC OFF", the "VSC TRAC", and the "slip-n-slide" indicator lights started coming on shortly after startup, about two days ago.

I just got two error codes from Auto Zone PO455 and PO441.

I am no mechanic in the technical sense but am mechanically inclined and would like to get to know my FJ more intimately......"if you know what I mean"
"wink wink, nudge nudge, say no more"
 

·
Registered
Joined
·
1,254 Posts
Is your gas cap on tight? Both those codes have to do with the fuel evaporative system, especially P0445 - evaporative emission system leak detected, large leak.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
Thanks for your input Canada. That seems to be the consensus. My cap has been checked. No change in the lights. I'm about to head under to check hoses and the electrical connectors I see around the charcoal box. I'll re-post in a bit.
 

·
Registered
Joined
·
560 Posts
Had that problem also but on my 08 scion (still a Toyota) and it was one of the wheel sensors that had gone bad.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #5
Had that problem also but on my 08 scion (still a Toyota) and it was one of the wheel sensors that had gone bad.
It's not likely but not impossible that I left the gas cap loose so I hope what I did ....sticks.

The electrical connector I saw earlier was for the e-locker. (checked it anyway) I inspected all of the hoses and clamps I could get my hands on and saw nothing out of the ordinary. I retightened the gas cap. The lights were still there after start up. Bummer!

Never had this problem before so I had a thought ......... "Maybe the computer needs resetting" so I disconnected the battery terminals for a few minutes. Voila' the lights were gone....but.... maybe only temporarily, so I drove around for a while, re-calibrated the compass, re-programed the radio......still no lights.

Fingers are crossed but I'll be back if the lights return.

Thanks for the input folks
 

·
Registered
Joined
·
1,254 Posts
Even if you tighten the gas cap, the 'lights' take a bit to realize that pressure has been re-established and reset themselves, but yes, disconnecting the battery usually works!
 

·
Registered
Joined
·
34 Posts
yes both those codes are for the evap system as outhers have said most likely u left ur fuel cap loose fj does not usually have evap issues but if u did clear the code by disconnecting the battery these codes are 2 trip diagnostic meaning it has to fail the evap check twice to set the dash lights but fj has a key off evap check and several conditions must be met for it to actually run such as veh must set for at least 4 hours, cannot be full of fuel, cannot be over 95f temperture and thier are more so it many take several cold soaks befor the lights return if they even do.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #8
yes both those codes are for the evap system as outhers have said most likely u left ur fuel cap loose fj does not usually have evap issues but if u did clear the code by disconnecting the battery these codes are 2 trip diagnostic meaning it has to fail the evap check twice to set the dash lights but fj has a key off evap check and several conditions must be met for it to actually run such as veh must set for at least 4 hours, cannot be full of fuel, cannot be over 95f temperture and thier are more so it many take several cold soaks befor the lights return if they even do.

Holy Crap! There's some details. Were you on the engineering team for the FJ? You just made me feel even stupider-er-er than I did for leaving my gas cap loose.

Duhhh....No lights yet, so there you have it folks. I can learn cause I are a smart monkey.
 

·
Registered
Joined
·
34 Posts
Holy Crap! There's some details. Were you on the engineering team for the FJ? You just made me feel even stupider-er-er than I did for leaving my gas cap loose.

Duhhh....No lights yet, so there you have it folks. I can learn cause I are a smart monkey.
lol thanks im no engineer but im a master yota tech professionally i diag these things daily.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #10
Man, I putting you in my "Friends" list voodoo ..........If I can figure out how to. lol
 
1 - 10 of 10 Posts
Top