Toyota FJ Cruiser Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
2013 6MT Quicksand
Joined
·
8 Posts
Discussion Starter · #1 ·
May seem like another TOB thread but not quite...

For some time now I have been browsing the forums for options on how to fix the dreaded chirp.
Among them was this clutch kit, mentioned only once on these forums (here).
There is also this post on forum.ih8mud.com, where a member kind of hints at this product.

The kit is available at More Information for AMS AUTOMOTIVE 16078R

Given that the kit has all essential parts for the job (clutch disc, clutch cover, the sleeve and the machined TOB to fit over it) and costs significantly less then equivalent products from URD, I'm surprised it hasn't received any attention at all.

Kindly asking anyone that has used this kit to voice their thoughts, whether the chirp came back and if yes then how many miles it took. Is it a viable alternative?
Also calling out @RWP87, as he is the one to first find out about it.
 

·
Registered
Joined
·
5,769 Posts
May seem like another TOB thread but not quite...

For some time now I have been browsing the forums for options on how to fix the dreaded chirp.
Among them was this clutch kit, mentioned only once on these forums (here).
There is also this post on forum.ih8mud.com, where a member kind of hints at this product.

The kit is available at More Information for AMS AUTOMOTIVE 16078R

Given that the kit has all essential parts for the job (clutch disc, clutch cover, the sleeve and the machined TOB to fit over it) and costs significantly less then equivalent products from URD, I'm surprised it hasn't received any attention at all.

Kindly asking anyone that has used this kit to voice their thoughts, whether the chirp came back and if yes then how many miles it took. Is it a viable alternative?
Also calling out @RWP87, as he is the one to first find out about it.
The CTX 153 pressure plate assembly is from Aisin, so it's not a non-name knockoff brand. (At least not if it's a real CTX 153)
 

·
Registered
2013 6MT Quicksand
Joined
·
8 Posts
Discussion Starter · #3 ·
I guess this is all the help I'm going to get. Thank you, @FJtest, I appreciate your observation.

I went ahead and ordered that kit. It will get installed sometime this summer. I will try to report back with my experiences in the due time.
 

·
Registered
Joined
·
215 Posts
Why not the Cluthchmasters hydraulic kit?
 

·
Registered
2013 6MT Quicksand
Joined
·
8 Posts
Discussion Starter · #7 ·
@moosetrophy, funny you ask now. I have completed the job last week and was just about to leave some word here.

100 miles on the kit and no problems at all. Obviously the chirp is gone.

I also installed new flywheel from LUK, replaced the TSB parts (slave cylinder, clutch release arm and arm support).
 

·
Registered
Joined
·
1 Posts
Still working good @sharkgoesmad? Been looking at that kit myself for a few months.

Which TSB is the whole release arm under? I thought it was just the slave cylinder and arm support.
 

·
Registered
2013 6MT Quicksand
Joined
·
8 Posts
Discussion Starter · #9 ·
A whole month and 500 miles since the job and still running strong. Regarding the release arm (or support fork), see the thread on tacomaworld.com.

The OP suggests replacing it and he makes a good point about it. The whole post is worth getting familiar with.
 
1 - 9 of 9 Posts
Top