Toyota FJ Cruiser Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
On the way to work this morning in the rain the engine light comes on. 2 seconds later the tractions light come on? It's an 08 6MT with 94K miles and has hardly seen a dirt road let alone a trail? Here's a picture. I would welcome any suggestions as to what the cause could be.
 

Attachments

·
Premium Member
Joined
·
2,265 Posts
The cause can be any number of trouble codes. Most trouble codes will deactivate the traction control. Get your cruiser scanned and report the code. We will tell you how to proceed from there.:cheers:
 

·
Registered
Joined
·
200 Posts
Did u ever find out what it was? My lights just started coming on too. But not the check engine. Only the abs, traction & vsc lights but no trouble codes are showing which makes this odd


Sent from AutoGuide.com App
 

·
Premium Member
Joined
·
2,265 Posts
Did u ever find out what it was? My lights just started coming on too. But not the check engine. Only the abs, traction & vsc lights but no trouble codes are showing which makes this odd


Sent from AutoGuide.com App
What kind of scanner are you using? Code readers won't see any codes other than PCM OBDii emission related codes. So for instance an ABS code will turn on your lights but a code reader won't see the code.
 

·
Premium Member
Joined
·
1,518 Posts
Does your 08 have the carbon canister for fuel vapors? If so, check the sensor on that. The sensor is on the passenger side of the canister, which is an about 8 or 9" square dark grey box under the rear of your FJ, if you don't know where it is. If that sensor goes bad (which mine has), your engine and traction control lights come on and stay on. You can turn them off, but they come right back on. The entire canister needs to be changed. I was quoted $1300 parts and labor for that at the dealership. I've learned to ignore the lights.
 

·
Registered
Joined
·
1 Posts
Hello guys,

New FJ owner here, I am barely 2 weeks fresh of buying my 2008 FJ with 78,000. I got it back from the toyota dealer after doing the 80,000 maintenance on it.
The check engine and all the rest of the yellow lights went off on me with slight vibration. It was scary for a bit, but I remember what I did different today.

I put premium fuel instead of super that is all that I did.

Can that be the cause of this situation? Do I need to send it back to the dealer, or can I just DIY it ?

Thanks
 

·
Registered
Joined
·
32 Posts
On the way to work this morning in the rain the engine light comes on. 2 seconds later the tractions light come on? It's an 08 6MT with 94K miles and has hardly seen a dirt road let alone a trail? Here's a picture. I would welcome any suggestions as to what the cause could be.
Mine did this today. I have the Torque App and it read a code of P0430 on bank 2. Did you ever figure out what yours was? I'm hoping mine isn't the cat b/c it's past 80k miles:flame:
 

·
Registered
Joined
·
1 Posts
The cause can be any number of trouble codes. Most trouble codes will deactivate the traction control. Get your cruiser scanned and report the code. We will tell you how to proceed from there.:cheers:
I have the same issue and when I scanned my car by OBD this code P0340 been showed up after searching I found there are 2 sensors and i replaced it but still, the issue exist

please i need fix it
 
1 - 8 of 8 Posts
Top