Toyota FJ Cruiser Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Have four warning lights on my 2007 FJ - Brake, Swerve, VSC off and VSC Trac. (see photo). An OBDII scan says 'no codes'. The FJ drives as usual.

A search of the forums indicates the most likely cause of this combination of warning lights is either 1) a malfunctioning speed sensor in the rear axle, or 2) a broken brake light switch.

Before I start throwing parts at the problem, is there anything else that could be causing this combination of lights? Which of the fixes would you try first, the speed sensor or the brake light switch?

Thanks!
 

Attachments

·
Registered
Joined
·
786 Posts
It doesn't look like your ABS light is on. Have you done any work recently or is the vehicle driving and braking differently. The first easy thing to check is fuses. Make sure they are all good using a volt/ohm meter.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
Thanks, so I checked all of the fuses that the manual says are connected with the brake system or traction control system. They are all okay.

Have not had any work done recently, although the truck has been out in the cold more than usual this winter.

Taking it to the repair shop later this week. Will post up the results.
 

·
Premium Member
Joined
·
477 Posts
No check engine light so there will not be any codes stored related to that. A common problem can that cause this is a broken speed sensor wire on the front wheels. Seen this all too often.

A shop with a professional type of scanner can identify what trouble code is set.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #5
There is a similar thread here:

http://www.fjcruiserforums.com/forums/engine-performance/96371-4-lights-death-abs-vsc-traction-contol-skid-control-questions.html

The difference is that FJ was showing ABS warning light, mine is showing Brake. The other three lights are the same. In the other thread someone said when the brake light switch goes out, the entire circuit goes with it and the FJ can not be shifted out of park.

Since mine still seems to drive the same, the problem is probably a speed sensor.
 

·
Premium Member
Joined
·
2,265 Posts
Your problem could be numerous codes. Don't throw any parts at it until you get it scanned. :cheers:
 

·
Premium Member
Joined
·
165 Posts
I got those 3 lights on the right on ...Im thinking speed senser It happened when I messed up my alignment busting through some ice.
 

·
Premium Member
Joined
·
1,070 Posts
haha I was just talking about this earlier today on a different thread. I have had these lights for a while. They are on and off which sucks. I've taken it in and had a sensor replaced and now they are thinking its a timing chain. I've heard this is a very rare repair but it is looking more and more like my problem is internal. My light show consists of check engine, VSC off, traction control off (slip), and VSC Trac. No brake light showing. Looks like we might have two different problems. Hope yours is warranty covered.
 

·
Registered
Joined
·
4 Posts
I have the same problem, and the brakes are not working, I did replaced the ABS ANTI-LOCK BRAKE PUMP MASTER CYLINDER BOOSTER
but still lights are on and the brake is not working

any advise please
 

·
Premium Member
Joined
·
11,019 Posts
I have the same problem, and the brakes are not working, I did replaced the ABS ANTI-LOCK BRAKE PUMP MASTER CYLINDER BOOSTER
but still lights are on and the brake is not working

any advise please
G'day,
First thing to do is take it to a mechanic or Toyota with a professional code reader to identify the cause and then you can correctly identify what is at fault, and get it fixed.
So many of these systems are related, without knowing the exact codes being issued, its is impossible to guess the cause.
Good luck,
cheers
Baz
 
1 - 14 of 14 Posts
Top