Toyota FJ Cruiser Forum banner
1 - 10 of 10 Posts

· Registered
Fj cruiser 2007
Joined
·
5 Posts
Discussion Starter · #1 ·
I have this problem when I go to start my fj the backlighting and radio along with the outside turn light flasher turn on and off. My fj will start it will do the same thing for a bit before turning off with no other light showing no check engine light no battery light runs good. Just changed the battery and the alternator. It all started to happen when I changed my water pump. After that everything stared to happen. Checked the voltage on the battery it was reading 12.7 volts after starting it was charging the battery at 13 Volts I can’t figure out this one out before start back dash lights flicker after start it dose it for a bit then goes away and at shut down everything’s flickers and goes away . Please help
 

· Premium Member
Joined
·
4,150 Posts
Mine does that too. The rheostat is dirty causing the lights to flicker. Run the dimmer for the dash lights up and down a few times. If that does not work, you may need to squirt some contact cleaner in the electronics of the dimmer.
 

· Premium Member
Joined
·
4,150 Posts
I’m still asleep. Leaving previous post in case someone finds it useful.

Try checking the ground cables. There are several clusters in the engine compartment and the main one from the battery. A good squirt of contact cleaner will help too.
 

· Registered
Fj cruiser 2007
Joined
·
5 Posts
Discussion Starter · #4 ·
Just verify all the ground connections all looked good cleaned with contact clean. Checked to voltage and alternator again all checked out good. I drove it today notice the battery voltage gauge moving around with in limits just jumps around
 

· Registered
Joined
·
7,941 Posts
If your "battery gauge" (more accurately the voltmeter) is "jumping" around at all, you have (most likely) an intermittent 'open' or intermittent high resistance connection somewhere in the B+ supply to the gauge cluster. Less likely is an intermittent short circuit.

You said you recently changed the battery and alternator - what was the problem that caused you to replace both?

Are you absolutely certain that you fully seated the plug-in connector to the alternator, and properly tightened the nut on the alternator output stud?

And that both the battery clamps and battery terminal posts were thoroughly wire-brushed to bare, bright metal before the clamps were reattached to the battery and the pinch-bolts were correctly tightened?
 

· Registered
Fj cruiser 2007
Joined
·
5 Posts
Discussion Starter · #6 ·
Just double checked everything brushed the battery terminals again checked and brushed the alternator connections checked and cleaned the alternator electrical plug checked for lose Wire and damage made shore it it was secure checked some relays still nothing change the alternator because from reading other forms online and have my battery die a few times. It was not charging my battery But I still get the back dash light flashing on and off for min and then goes off even when I take the key of the igniter I can start the vehicle and it will run with the back light flashing with no engine check light or any type of mx light. Also try red resting any mx codes went to auto zone and got these codes c1223 malfunction in abs controls sys c1241 low battery positive voltage or abnormally high battery positive voltage c1249 open circuit in stop light switch circuit. Got these codes but do not have abs light that comes on and done have any abs issue that I know of.
 

· Registered
Joined
·
7,941 Posts
OK, those codes are critical, and relate to a possible fault in the ABS system.

Normally, after the vehicle has sat for a few hours, when you first turn the key to the RUN position (do not start the engine), the ABS accumulator pump will run for a few seconds to pressurize the accumulator.

If you just turn the key to the RUN position, do you see the flickering lights during the few seconds that the ABS pump is running, BEFORE the engine is started? Or does the flickering only occur AFTER the engine is started?

Font Material property Rectangle Parallel Number



Font Parallel Document Screenshot Number
 

· Registered
Joined
·
7,941 Posts
It flickers in the run position and in the engine run position
Ehhh? Sorry, that doesn't make sense.

You mean you have flickering when the ignition key is in the RUN position, when the engine is NOT running, as well as flickering when the engine IS running?

And no change in flickering regardless if the ABS boost pump is running or not running?
 
1 - 10 of 10 Posts
Top