Toyota FJ Cruiser Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
All,

I've had some hard starting issues on my 07 FJ from 60k till now (80k). At first, the FJ would just crank excessively only on occasion. Eventually, the FJ would crank excessively anytime it sat for about an hour. It always started up fine from cold, whether it be overnight or after 2 weeks. By excessive cranking, I mean that the starter worked fine, and the engine would turn over and over and over without ever catching. Once it did start, I could always smell gas. Some of the things I tried:

- Cleaned the MAF (yes the MAF, not the temperature sensor)
- Replaced the MAF
- Replaced the spark plugs
- Reset the ECU many times by pulling battery power
- Tried the thermostat replacement (yeah, that was a stretch - I was getting desperate)
- Tried all kinds of fuel injector cleaners
- Tried fuels without ethanol

My FJ never threw a code, and all sensor parameters were within spec.

Eventually, a local mechanic dug into the problem and found two of my fuel injectors were leaking more than the "couple of drops" every so many minutes. I ordered a complete set of 6 rebuilt GB injectors and had the mechanic put them in. I've put 1000 miles on the FJ since then and have not had any starting issues. My FJ now consistently starts up after 5 revolutions (I don't know if this is 5 revolutions, but if you listen to your FJ start and count the sounds you'll know what I mean) regardless of outside temperature or recent driving history. Before swapping injectors, this would vary from 3 to 20 or more.

My MPG is the same as it has ever been (19.5 on a good tank).

I've read others struggling with this same issue. I've never felt like this was a FJ or Toyota thing. Hope it helps....
 

·
Premium Member
Joined
·
1,588 Posts
Welcome and thanks for sharing!

Personally I have not heard of this being an issue on the FJs, most likely just bad luck, glad you (well, the mechanic) was able to find the problem and fix it...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I'm not sure this is a bad luck thing. There are a number of posts on this forum with similar symptoms, but they may be unrelated. My particular solution is not something I would recommend to others without a little bit of diagnostics first. Having said that, I don't accept other posts (on this forum and others) that Toyotas naturally tend to excessive cranking. There is no reason for this.
 

·
Registered
Joined
·
1 Posts
That is exactly the same symptoms I am having, sits for an hour, has extended crank, overnight okay,sits for weeks okay. I too have smelled gas. This afternoon I recreated the hard start, I removed all the plugs hoping to see a cylinder or two with wet plugs, but no luck.
 
1 - 4 of 4 Posts
Top