Toyota FJ Cruiser Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter #1
Ok 2010 4x4 at 130k,
Trying to figure out my bad misfire.
Went to mardi krawl 8hr away no issues. Wheeled it hard all weekend no problem. 8hr drive home no issues. 2 days after had a guy pull out in front of me and instead of hitting them. I should have, I took the curb at 25mph the fj shut down running wise. Finally got it to run good enough to get home with a bad misfire.
Here's what I've done
Change plugs- no change
Checked coil packs- all fireing
Checked fuel pressure before regulator- 50 or so psi
Cleaned maf- no change.
Ran a can of valve cleaner- ran better while spraying
Codes are p0300, p0304. So random misfire and a misfire on cyl 4. Sometimes tells me lean on bank 1.
I'm planning on pulling injectors today and clean them if my kit comes in today.
Checked fuel for water- no water
Checked for a vacuum leak- couldn't find one.
Looked over the o2 no damage found

Its strange that it started after taking that curb but didn't feel like a hard hit. What are yalls ideas on this.

Sent from my SM-N960U1 using Tapatalk
 

·
Premium Member
Joined
·
2,843 Posts
Knocked some crud in the fuel system loose and got sucked up into an injector?
 

·
Registered
Joined
·
4,078 Posts
Please clarify the statements below:

1. "I took the curb at 25 mph the fj shut down running wise".
Do you mean the engine shut off dead instantaneously on impact, it started running rough instantaneously on impact, or it started running rough at some point after the impact?

.2. "Finally got it to run good enough to get home with a bad misfire."
Exactly what did you do that "finally got it to run"?

3. "Took the curb at 25 mph"
Do you mean you scuffed the curb with both wheels on one side of the vehicle while travelling parallel to the curb, you jumped the curb with both wheels on one side of the vehicle, both front wheels impacted a curb at 90 degrees, or all four wheels jumped the curb?

Trying to isolate an electrical problem vs a fuel-supply related problem vs a fuel mixture problem.

Did you check the tightness of all the clamps on the intake tract between the MAF sensor and the throttle body?
 

·
Registered
Joined
·
117 Posts
Ok 2010 4x4 at 130k,
Trying to figure out my bad misfire.
Went to mardi krawl 8hr away no issues. Wheeled it hard all weekend no problem. 8hr drive home no issues. 2 days after had a guy pull out in front of me and instead of hitting them. I should have, I took the curb at 25mph the fj shut down running wise. Finally got it to run good enough to get home with a bad misfire.
Here's what I've done
Change plugs- no change
Checked coil packs- all fireing
Checked fuel pressure before regulator- 50 or so psi
Cleaned maf- no change.
Ran a can of valve cleaner- ran better while spraying
Codes are p0300, p0304. So random misfire and a misfire on cyl 4. Sometimes tells me lean on bank 1.
I'm planning on pulling injectors today and clean them if my kit comes in today.
Checked fuel for water- no water
Checked for a vacuum leak- couldn't find one.
Looked over the o2 no damage found

Its strange that it started after taking that curb but didn't feel like a hard hit. What are yalls ideas on this.

Sent from my SM-N960U1 using Tapatalk
so do you have a scanner if so that will help you find out watch your fuel trims also clear codes swap coil #4 with a different one check for codes see if misfire moves from cylinder4
 

·
Registered
Joined
·
159 Posts
Discussion Starter #5
so do you have a scanner if so that will help you find out watch your fuel trims also clear codes swap coil #4 with a different one check for codes see if misfire moves from cylinder4
I do have a reader but I don't know what I'm looking at for my short term fuel trim. I can view current cc but not for individual injectors.
Swaping coil packs no change.

Sent from my SM-N960U1 using Tapatalk
 

·
Registered
Joined
·
159 Posts
Discussion Starter #6
Please clarify the statements below:

1. "I took the curb at 25 mph the fj shut down running wise".
Do you mean the engine shut off dead instantaneously on impact, it started running rough instantaneously on impact, or it started running rough at some point after the impact?

.2. "Finally got it to run good enough to get home with a bad misfire."
Exactly what did you do that "finally got it to run"?

3. "Took the curb at 25 mph"
Do you mean you scuffed the curb with both wheels on one side of the vehicle while travelling parallel to the curb, you jumped the curb with both wheels on one side of the vehicle, both front wheels impacted a curb at 90 degrees, or all four wheels jumped the curb?

Trying to isolate an electrical problem vs a fuel-supply related problem vs a fuel mixture problem.

Did you check the tightness of all the clamps on the intake tract between the MAF sensor and the throttle body?
All clamps good.
Instantly started running rough. No power.
I'm not sure what I did to get it to run better.
I did pull the fuel lines off to see if it was pumping fuel, and just kept trying to keep it alive while reading and clearing codes. ( previous experience with a bmw i had. When it developed a misfire randomly i could clear the code and it would run fine till a month or so later)
Both pasenger wheel and tire went over the curb at about 25mph. Let off the brake right before. Did not touch gas till I was past it.

Sent from my SM-N960U1 using Tapatalk
 

·
Registered
Joined
·
159 Posts
Discussion Starter #10
Knocked some crud in the fuel system loose and got sucked up into an injector?
Not sure. I have a cleaning kit coming in and hopefully I can start cleaning the injectors tomorrow and back flushing them. I'm hoping I find some not spraying good or inop in general. Then I shouldn't bave to keep looking. Just hoping my ecu didn't **** the bed.

Sent from my SM-N960U1 using Tapatalk
 

·
Registered
Joined
·
4,706 Posts
Did you unhook the battery to reset the computer? Might be worth a try and its cheap to do :)
 

·
Registered
Joined
·
117 Posts
so do you have a scanner if so that will help you find out watch your fuel trims also clear codes swap coil #4 with a different one check for codes see if misfire moves from cylinder4
All clamps good.
Instantly started running rough. No power.
I'm not sure what I did to get it to run better.
I did pull the fuel lines off to see if it was pumping fuel, and just kept trying to keep it alive while reading and clearing codes. ( previous experience with a bmw i had. When it developed a misfire randomly i could clear the code and it would run fine till a month or so later)
Both pasenger wheel and tire went over the curb at about 25mph. Let off the brake right before. Did not touch gas till I was past it.

Sent from my SM-N960U1 using Tapatalk
sorry again also check exhaust were connection is in front of rear cat
 

·
Registered
Joined
·
159 Posts
Discussion Starter #18
ideal fuel trim is 0 to 7%
Short term fuel trim is 0. Even while reving up to about 3k.
Just cleaned the injectors, all are spraying good. And all are getting power. When the engine is being turned over.


Sent from my SM-N960U1 using Tapatalk
 
1 - 20 of 28 Posts
Top