Toyota FJ Cruiser Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Looking for some input on a conflict I am having between my stock FJammer and my HID conversion from All Pro. The conversion is insanely good, but when the lights go on, the radio reception goes to hell! Can someone toss out a correction for this? Thanks!
 

·
Registered
Joined
·
277 Posts
Looking for some input on a conflict I am having between my stock FJammer and my HID conversion from All Pro. The conversion is insanely good, but when the lights go on, the radio reception goes to hell! Can someone toss out a correction for this? Thanks!
i really dont think the HID light kit has alot to do with your radio reception, if the kit is plug n play, if not just makesure u have a SOLID Ground connection.
i also have HIDs and i havnt had that problem.
Good Luck:)
 

·
Registered
Joined
·
911 Posts
Weird men, i also have HID's on my FJ and i have no issues like this, i can suggest to check youre ground connections, try to put them by them selfs.

other than that it should be only a 12V connection to the battery, plus the connection to the lights it self.

Good luck..
 

·
Registered
Joined
·
570 Posts
If the grounding is solid - I'd suspect a bad ballast. Check the grounding first, if you're still having the problem, try disconnecting the inputs to ballasts (the 12V side, not the lamp side) one at a time.
 

·
Banned
Joined
·
321 Posts
Looking for some input on a conflict I am having between my stock FJammer and my HID conversion from All Pro. The conversion is insanely good, but when the lights go on, the radio reception goes to hell! Can someone toss out a correction for this? Thanks!
have a hid kit on my 2003 corolla

the same thing happens, lights go on, reception gets way worse

keep in mind those "kits" are far from factory quality, nothing you can do about it
 

·
Registered
Joined
·
2,165 Posts
I too have HIDs, and it has absolutely no effect on the radio, definitely a bad ground.:bandit:
 

·
Registered
Joined
·
2,822 Posts
sounds like a cheap HID kit.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
I spoke to Terry at All Pro and he was great. I moved one ground straight to the battery and the reception improved dramatically. I will run a longer ground line from the other side and hope all go back to normal. Thanks for the feedback!
 
1 - 9 of 9 Posts
Top