Toyota FJ Cruiser Forum banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2007 FJ and 4 wheel Parts installed the Pro Comp "3" lift today with a set of Pro Comp 285/70 R-17 A/T tires on a set of Pro Comp 17x9 wheels. The guy that helped me called me this evening and said they have it done but there is a shimmy when driving. They did an alignment and balanced everything. He said there might be something wrong with my rack in pinion and said he heard some popping in my gear box?? I have 40,000 miles on this vehicle and have never had any issues with this.... The sales guy said he would put it back up the rack tomorrow and see what they could find. Any suggestions on what could be going on??
 

·
Registered
Joined
·
505 Posts
You had no problem before you brought your FJ in to get work.

Put your old tires and rims back on!

I bet its the new tires and rims with a balance problem.
 

·
Registered
Joined
·
1,187 Posts
Is there any chance the popping could be your cv joints due to extreme angle?
I don't know that anyone else with a 3" lift has had that problem (at least overwhelmingly). Might be 4 Wheel Parts installation. I hear mixed reviews (mostly bad) about their mechanics.
 

·
Registered
Joined
·
527 Posts
I don't know that anyone else with a 3" lift has had that problem (at least overwhelmingly). Might be 4 Wheel Parts installation. I hear mixed reviews (mostly bad) about their mechanics.
I won't even let those idiots put on wheel spacers!! I would pay more to go somewhere else.
 
1 - 5 of 5 Posts
Top