Toyota FJ Cruiser Forum banner
  • Hey everyone! Enter your ride HERE to be a part of JULY's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
483 Posts
Discussion Starter · #1 ·
ok, so i got my 16inch atx mojave wheels and a set of dick cepek tires mounted and balanced by tirerack and installed them yesterday, couldnt drive till today, but the balancing weights fell off today in my drive way on the front 2 wheels because they were rubbing against my calipers

theres still a strange tick noise coming from the rear, idk if any one else has this problem, but let me know if you did id greatly appreciate it. also the solution they use to lubricate the rim while installing the tire, they left a lot of liquid inside the tire, so it swishes, and shwooshes around when i brake, some is oozing out so hopefully the rest will

just goes to show that free mounting and balancing stinks, i guess you get what you pay for, and that would be nothing...thanks a lot tirerack
 

·
Premium Member
Joined
·
6,531 Posts
How did you determine the weights got knocked off by the calipers? Seems to me if that were really the case, the weights would have been knocked off on the first few rotations of the tire.

TireRack is a very good outfit. The quality (and price you paid) of the mount and balance has nothing to do with the wrong wheels being installed on a vehicle.

Do you have "stock calipers" or the "TRD big caliper kit"?

DEWFPO
 

·
Registered
Joined
·
483 Posts
Discussion Starter · #3 ·
thanks for posting back.....ive got stock calipers...they came off by the end of my drive way the first time i rolled off on the new tires, there were scuffs from the calipers on the weights, i can post a pic tomorrow of the weights, but theres also a ticking noise coming from the right rear tire, i think theres something rubbing lol,
 

·
Registered
Joined
·
483 Posts
Discussion Starter · #4 ·
but when i called them up they said the atx's would fit on the stock fj, ive seen other forum members with them but for some reason ive run out of luck
 

·
Premium Member
Joined
·
6,531 Posts
You need to check the offset on the rims they sent you. It appears your wheels have the wrong offset. It also sounds like your rear wheel weights are getting ready to be ripped off as well.

If I'm reading this correctly..... you ordered the tires/rims from Tirerack, they shipped them to you, you installed them in your driveway and as soon as you put it into reverse and rolled back a little the front wheel weights came off.

DEWFPO
 

·
Registered
Joined
·
483 Posts
Discussion Starter · #6 ·
You need to check the offset on the rims they sent you. It appears your wheels have the wrong offset. It also sounds like your rear wheel weights are getting ready to be ripped off as well.

If I'm reading this correctly..... you ordered the tires/rims from Tirerack, they shipped them to you, you installed them in your driveway and as soon as you put it into reverse and rolled back a little the front wheel weights came off.

DEWFPO
thats exactly what happened, so does that mean i have to order different wheels
 

·
Registered
Joined
·
2,698 Posts
So do you still have a problem or did you figure it out?
 
1 - 8 of 8 Posts
Top