Toyota FJ Cruiser Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all, FJ hasn't been started in 2 months, engine cranks nicely but won't fire, none of the dashboard lights are working, all other electrics such as windows and lights are working. Appreciate any ideas, Thanks.
 

·
Registered
Joined
·
1,530 Posts
Either rodent damage to the wiring, or corrosion and connection issues with the wiring/battery/ground cables since it's been sitting so long. I'd go with rodent chewing of the wires somewhere as the likely culprit, but the quickest thing to check first is if any fuses in the fuse box are blown.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Either rodent damage....
You're correct, there have been rodents in the engine compartment, they've chewed the window washer piping and left a lot of droppings. The fuel gauge is now showing empty despite a full tank and the back door won't open. Considering myself very lucky that everything else seems to be working, going to get an auto electrician to thoroughly check. Thanks for your reply.
 

·
Registered
Joined
·
1,530 Posts
Check the wiring in the top of the engine under the manifold. That seems to be a favorite nesting place for mice. Good luck. My sister is battling hordes of mice in Arizona this year. They're into the house like a plague. I didn't know they like ground coffee, but they got into coffee pods of all things. But it kills them if they gorge on it. Must be caffeine poisoning that does them in.
 
1 - 10 of 10 Posts
Top