Toyota FJ Cruiser Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello all, my wife drives a 2008 FJ cruiser. Automatic. We just had a snap of cold weather. (Below -40) speedometer stopped working on her way home from work. Check engine and brake light came one. Gauges have been bouncing around, fuel gauge dropping to empty then back up to half, sometimes rpm gauge drops to zero then back up. Also abs, Vsc, trac, and the other light on.
PO500 is only engine code which is VSS
ABS scan gives
CO200 front speed sensor RH circuit
CO205 front speed sensor LH circuit
CO210 rear speed sensor RH circuit
C0215 rear speed sensor LH circuit
C1201 engine control system
C1223 engine control system malfunction
C1235 foreign matter is attached on the tip of right front sensor
C1241 low or high power supply voltage
C1249 open circuit in stop light switch circuit
C1253 hydro-booster pump motor relay
C1256 Accumulator low pressure
I am at a loss of where to start diagnostics as so much came up at once.
does anyone have any ideas, or a similar thing that has happened?
Any help is appreciated
 

·
Premium Member
Joined
·
882 Posts
Good start is to disconnect the battery, wait a few minutes, and reconnect. Sometimes the ECU needs a reboot.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Good start is to disconnect the battery, wait a few minutes, and reconnect. Sometimes the ECU needs a reboot.
I have done that, also reset engine code with one scanner. Engine light went out for a few mins then came back on. All other lights stayed on
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Mine doesn’t have a block heater, so stuck driving hers like this until it warms up.
idle is dropping to around 400 rpm as well
 

·
Registered
Joined
·
3,259 Posts
Intermittent electrical connection related to the B+ (battery) supply.

Obviously, dozens of unrelated electrical faults are not going to occur simultaneously, unless the vehicle was submerged in salt water. The common element is likely low system voltage.

Five initial questions:
a) How many miles on the vehicle?
b) How old is the battery?
c) Has the alternator ever been serviced or replaced?
d) Was the instrument cluster voltmeter indicating a normal system voltage, and was there any bouncing around of the voltmeter needle while the engine was running?
e) Have you inspected the condition and tension on the serpentine accessory drive belt?

1. First, use an accurate digital multimeter to measure the voltage at the battery terminals 30 minutes after the engine was shut off. The voltage should be between 12.6 and 12.9 volts at 65-68 degrees F.

2. With the engine running at ~2,000 RPM in PARK, and all other electrical loads turned OFF, the voltage should be between 13.2 and 14.8 volts.

Post your voltage measurements here, and we'll walk you through some simple troubleshooting steps.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Intermittent electrical connection related to the B+ (battery) supply.

Obviously, dozens of unrelated electrical faults are not going to occur simultaneously, unless the vehicle was submerged in salt water. The common element is likely low system voltage.

Five initial questions:
a) How many miles on the vehicle?
b) How old is the battery?
c) Has the alternator ever been serviced or replaced?
d) Was the instrument cluster voltmeter indicating a normal system voltage, and was there any bouncing around of the voltmeter needle while the engine was running?
e) Have you inspected the condition and tension on the serpentine accessory drive belt?

1. First, use an accurate digital multimeter to measure the voltage at the battery terminals 30 minutes after the engine was shut off. The voltage should be between 12.6 and 12.9 volts at 65-68 degrees F.

2. With the engine running at ~2,000 RPM in PARK, and all other electrical loads turned OFF, the voltage should be between 13.2 and 14. volts.

Post your voltage measurements here, and we'll walk you through some simple troubleshooting steps.
I can answer a few right now
Vehicle has 264,000 km
Battery is 4 years old
Unsure of alternator (bought it 3 years ago )
Instrument cluster volt meter was bouncing, however all gauges were as well. (But when gauges weren’t bouncing a few mins ago I could hear heater fan slowing down and voltage drop on cluster)
Serpentine belt and tension appear correct
Engine running I’m reading 13.5-13.9 on battery
Engine off for 1 hour 11.9
It is -40 out so can’t get too good of readings from battery

no driving in salt water ;)
I think the oceans would be frozen over in these temps
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Also had a wheel bearing go out on front passenger side a few months ago. Which caused the abs, vsc, trac etc lights to come on. After replacing the wheel bearing they have intermittently come on.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Haven’t had a chance to troubleshoot any more yet. Getting married in 3 days, then off for a week honeymoon. Still hoping for any tips on where to start.
 

·
Registered
Joined
·
687 Posts
Is there a possibility in that challenging weather a curb possibly been tapped and knocked the alignment out of wack


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Is there a possibility in that challenging weather a curb possibly been tapped and knocked the alignment out of wack


Sent from my iPhone using Tapatalk
No, there was nothing like that. The wife drove home from work and said her truck was as dying. I’m a heavy duty mechanic. So it’s embarrassing that I can’t figure it out lol. Electrical issues confuse me
 

·
Admin
Joined
·
6,858 Posts
Try parking it in a buddy's heated garage and let everything melt and dry off.... ice can get in all kinds of weird places.

I also have put dielectric grease on most connectors.... including the speed sensors to keep moisture out.

Never hurts to be able to spend some time out of the elements when diagnosing frustrating things too.... if you were local I'd offer my garage.... for the low price of a beer 🍻
 
1 - 14 of 14 Posts
Top