Toyota FJ Cruiser Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1 (Edited)
I just installed the Pro Comp 3 inch lift on my 2007 FJ. Been on for about 400 miles so far. It's rides better than the old stock suspension, however, when I hit tiny bumps it sometimes seems like it skips across the top of the bump without actually working. Almost like the steering goes really loose for a split second. I have checked everything, and everything I had to touch is still tight. Is it that much more stiff, or could there be something that is binded somewhere?

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
1,951 Posts
Did you re-do the alignment after after installing the lift? They can be a squirrely on handling if you dont get them aligned after a lift and closer to factory alignment specs.

Your title also mentions weird sound, but i dont see within your post anything describing the sound and when it happens...just the mention of the bump steer issue.

Can you clarify further?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Just on small bumps it almost sounds like metal hitting metal. Not loud, but annoying as hell. I haven't got it in for an allignyyet because up here in Alaska, it's tire changeover season, and all the shops are two weeks out. I have an appointment though.

Sent from my SM-G955U using Tapatalk
 

·
Forum Beer Miester
Joined
·
3,940 Posts
I just installed the Pro Comp 3 inch lift on my 2007 FJ. Been on for about 400 miles so far. It's rides better than the old stock suspension, however, when I hit tiny bumps it sometimes seems like it skips across the top of the bump without actually working. Almost like the steering goes really loose for a split second. I have checked everything, and everything I had to touch is still tight. Is it that much more stiff, or could there be something that is binded somewhere?

Sent from my SM-G955U using Tapatalk
Yep dude I'm afraid it is that much more stiff. Wish I could've got to ya before you purchased the Pro Comp because I would've tried to get you to save you're money for a more expensive kit because this kit is pretty harsh. I've got this kit sitting in a shed because I won't even give it away I disliked it so much.

Change the UCA's, align it and it'll get smoother because it's in a bind and this will help a little.
 

·
Forum Beer Miester
Joined
·
3,940 Posts
Just on small bumps it almost sounds like metal hitting metal. Not loud, but annoying as hell. I haven't got it in for an allignyyet because up here in Alaska, it's tire changeover season, and all the shops are two weeks out. I have an appointment though.

Sent from my SM-G955U using Tapatalk
Check all the ball joint nuts and tie Rod ends to assure they're tight. Also double check the upper and lower coilover mounts. All these things will make a hell of a clunk on small bumps if one's loose.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
Believe it or not, It was the sway bar mounts. The idiot that was helping didn't tighten them evidently. I thought I went through everything he did, but I guess not.

Sent from my SM-G955U using Tapatalk
 
1 - 7 of 7 Posts
Top